Service Degradation: Specific Nevis ID Instances
Minor incident
Nevis ID
2026-05-06 09:27 CEST
· 3 minutes
Updates
Issue
May 6, 2026 · 15:57 CEST
Summary: We have identified a minor issue affecting a subset of Nevis ID instances.
Impact: While the majority of the service remains healthy, specific customer instances may experience degradation of the service.
Status: Our engineering team is currently investigating the root cause and is actively working to restore the affected service as quickly as possible.
Update
May 6, 2026 · 09:30 CEST
After a period of stable monitoring, we have confirmed that all services have returned to normal operation. The issue is successfully resolved. We will conduct a post-incident review to prevent recurrence.
← Back
Status