Nevis yoU e-learning platform is down

Minor incident Nevis Portal Nevis yoU
2024-02-02 08:42 CEST · 1 day, 1 hour, 16 minutes

Updates

Resolved

Our e-learning platform service has been successfully restored and is now up and running. We appreciate your patience and understanding during the temporary interruption.

February 3, 2024 · 09:56 CEST
Issue

Our e-learning platform Nevis yoU is currently experiencing an outage. Our technical team is actively investigating the issue to identify and address the root cause.

February 2, 2024 · 08:42 CEST

← Back