Issue with accessing Nevis Portal

Minor incident Nevis Portal Support Portal Nevis yoU
2024-01-02 10:04 CEST · 4 hours, 30 minutes

Updates

Resolved

We are pleased to inform you that the technical issue affecting our Portal service has been successfully resolved. The service is now back online, and you can resume your usual activities.

Our technical team has worked diligently to address the issue promptly, and we appreciate your patience and understanding during this brief interruption.

January 2, 2024 · 14:34 CEST
Issue

We regret to inform you that our Portal service is currently experiencing technical difficulties, and as a result, it is temporarily unavailable.

Our dedicated technical team is actively working to resolve the issue and restore full functionality as soon as possible. We understand the inconvenience this may cause, and we appreciate your patience and understanding during this time.

January 2, 2024 · 10:04 CEST

← Back